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Training Files Used in This Lesson 

• Folder files in 
C:\Users\Public\Documents\Wiley\KnowItAll\ 
Samples\LC-MS 

KnowItAll Applications Used 

• KnowItAll LC Expert 

• KnowItAll MineIt 

• KnowItAll ReportIt 

Automatic LC-MS Processing and Analysis 
How to use KnowItAll LC Expert to Perform Automatic LC-MS Component Identifications 

 

Purpose 
 
These exercises demonstrate how to use KnowItAll LC Expert to analyze raw LC-MS chromatograms using automatic and manual tools. 
 

Objectives 

 
These exercises will teach you how to: 

➢ Use KnowItAll LC Expert to deconvolute chromatograms into peaks for further analysis 

➢ Perform an untargeted databases search 

➢ Perform a targeted analysis search by exact mass 

➢ Use manual tools to allow for user-lead peak selection 

 

Background 

LC-MS chromatograms are rich in information. Analysis is challenging and curated libraries are 

time consuming to search through. LC Expert application allows for the automatic deconvolution of 

the chromatogram into peaks, which can be further analyzed and then searched for known and 

unknown targets. Users of LC Expert are encouraged to create user libraries with their in-house 

compounds to streamline their workflows using KnowItAll. 

 

 



  

108658-REV20250822 Copyright ©2025 by John Wiley & Sons, Inc. All rights reserved. 

KnowItAll Training                                                                                                        LC Expert 3 

Example: Open a Chromatogram in LC Expert 

 Action Result 

1  Open LC Expert application by clicking on 

the icon ( ), typically found in the 
Spectral Processing toolbox. 

 

LC Expert application is displayed: 

 
Note: LC Expert must be in your current license to have access to the application.  

2  Go to the View panel and confirm that the 
Database Search Bar is selected with a 
checkmark. If there is no checkmark, click 
on the row highlighted below to select it. 

 

As shown in the previous step, the Database Search Bar is displayed in the application, typically on the 
righthand side of the screen. Note: It can be undocked and moved around by clicking on the blue title bar for 
the panel. 
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 Action Result 

3  Click Open Raw LC-MS Data File button. 
Navigate to “C:\Users\Public\Public 
Documents\Wiley\KnowItAll\Samples\LC-
MS\”. 

Select “TESTMIX2_180504_MAS011_06 
.mzXML” and open in the application. 

The LC-MS file opens in LC Expert application: 

 

4  Investigate the different panels displayed in 
the LC Expert application. 

 

• The detected ion polarity is displayed in the Ion Mode panel ( , inset A), located on the 
Standard Toolbar. 

• The top panel ( , inset B) displays the Chromatogram with Peak Boxes for each peak. 

• The second panel is the Raw Spectrum panel ( , inset C) in which the extracted 
spectrum and raw spectrum are displayed. 

• The third panel is the Database Match panel ( , inset D) which displays the search 
match MS/MS spectrum for the selected peak.  

• The bottom panel is the Peaks Table ( ,inset E) which shows the deconvoluted peaks 
generated from the Chromatogram. The rows in the table include information about each peak. 

• The Database Search bar ( , inset F) is located on the righthand side and displays 
any tandem MS search results for the peaks. 

Note: Database search matching will be discussed in greater detail in the next section. 
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 Action Result 

5  Confirm that the Analysis Method 
dropdown menu on the Standard Toolbar 
is set to Deconvolution mode.  

 

Note: LC Expert retains the last applied 
method. 

 

 

The Analysis Method is set to Deconvolution:  

 

Three different Analysis Method options are available in the dropdown menu: Deconvolution, Peak Picking, 
and Manual.  

• Deconvolution: Correlated MS scans are automatically grouped together into peaks. The averaged 
MS1 scan for the peak is provided in the Raw Spectrum pane, labelled MS Level 1 Extracted 
Spectrum. The Peak Table populates with peak information (e.g., Peak Area, Peak Area Percent 
[%]). 

• Peak Picking: A single time point is automatically used to characterize the peak and the Peak Area 
and Peak Area [%] columns are replaced with ‘ – ‘ symbols. Using this method, the Raw Spectrum is 
equivalent to the Extracted Spectrum. 

• Manual method enables manual peak selection by the user and will be discussed in a following  
section.  

6  To adjust the peak deconvolution settings, 
select View > Deconvolution Settings 
Bar. 

The Deconvolution Settings bar is opened. The Deconvolution Settings bar can be used to tune the 
deconvolution and instrument resolution: 
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 Action Result 

7  To change the Instrument Resolution, go 
to the Deconvolution Settings bar and 
click the checkbox in the Instrument 
Resolution panel next to Advanced. 

 

The Advanced Resolution Settings popup appears. 

 

8  Click Cancel on the popup to close the 
dialog.  

The popup closes. 

9  Go to the Deconvolution Settings bar and 
deselect the checkbox next to Automatic in 
the Deconvolution panel.  

 

The Resolution, Sensitivity and Peak Shape Requirements become available for adjusting. The slider bars 
or numeric values can be used to control the deconvolution settings. As the deconvolution settings are 
changed, the number of peaks in the Peaks Table and Peak Boxes on the Chromatogram are changed. 

 

10  Click to reselect the checkbox next to 
Automatic.  

Select the exit icon ( ) on the 
Deconvolution Settings panel to hide the 
panel. 

The application resumes automatic deconvolution for the peaks. The Deconvolution Settings panel becomes 
hidden. 
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 Action Result 

11  Click the Include Range Bar with left 
mouse button and drag left/right to select a 
region for analysis. 

 

Note: This can also be achieved by clicking 
on the Include Range Bar with the right 
mouse button. On the proceeding pop-up 
Include Ranges dialog, click Add. A space 
below Low Range will appear to manually 
input a value. Do the same below High 
Range to manually input a value. Click OK. 

The Include Range Bar can be used to isolate analysis regions in the Chromatogram. Outside of these 
regions (shown in gray coloration on the Chromatogram), there is no deconvolution or additional analysis 
taking place: 

 

12  To remove the isolated regions from the 
Include Range Bar, click the trash can icon 

( ) on the right side of the Include 
Range Bar. 

The isolated regions are removed from the Chromatogram, and the full chromatographic region is 
deconvoluted: 
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 Action Result 

13  Click on the peak box ( ) for the tallest 
peak (located at 8.93 min). 

Upon peak selection for the peak at 8.93 min: 

• The Peak Box is shaded to confirm selection. 

• The Peak Area is shaded with blue coloration, displaying the deconvoluted peak area. 

• There is a Bracket above and below the peak, to visualize the retention time region for the peak. 

• The related row in the Peaks Table is highlighted. 
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 Action Result 

14  Click on another row in the Peaks Table 
(e.g., row 21). 

The related peak in the Chromatogram becomes selected:  

• The Peak Box is shaded with a darker coloration. 

• The Peak Area is shaded. 

• The retention time region is indicated by the bracket. 

 

Note: If a peak’s component can be identified by the user, its name can be manually entered into the Peaks 
Table by double clicking on the associated cell in the Annotated Name column. 

15  To save the file, select File > Save LC 
Expert File. 

An LC Expert Analysis file is saved to the location of your choosing.  

 

This file can be reopened to re-analyze datasets, or continue processing in the future. 
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Example: Perform an Untargeted MS2 Search 

This section explains how to perform an untargeted library search for MS/MS data. 
 

 Action Result 

1  Continue using the chromatogram file from 
Step 2. In LC Expert, select File > 
Settings. In the Settings popup that 
appears, choose the Databases tab.  

Make sure the Search Tandem MS 
Spectra checkbox is selected. 

 

 

The Settings dialog opens.The Databases menu displays search settings:  

 

The specific databases displayed in the panel below Available for Searching depend on the user license. 

2  To choose all of the databases available 
for searching, select the radio button for 
Search All Licensed Reference 
Databases.  

Alternatively, select database(s) can be 
searched by using the radio button for 
Search Selected Databases and 
individually double clicking on the titles to 
add the desired libraries. 

When the radio button for Search All Licensed Reference Databases is selected, then the Selected for 
Searching window is unavailable. When the radio button for Search Selected Databases is selected, then the 
Selected for Searching window is available. 

 

Note: Specific available databases depend on the user’s license. User databases can be added for searching 

by selecting the Select by Browsing button ( ) and navigating to the desired database file 
(.sdbx). 

 



  

108658-REV20250822 Copyright ©2025 by John Wiley & Sons, Inc. All rights reserved. 

KnowItAll Training                                                                                                        LC Expert 11 

 Action Result 

3  Click Apply then OK to save any changes 
made in the Settings dialog.  

Note: To stop the database search from 
taking place in the background within the 

software, deselect the related icon ( ) 
located on the Standard Toolbar, or turn 
off the database search setting from Step 
1. 

The Settings dialog is closed. In the Database Search panel on the righthand side: 

• The deconvoluted peaks were searched using the selected libraries. 

• The peak retention times (RT [min]) in the Database Search panel are aligned to the peaks in the 
Peaks Table. 

• Clicking on a row in the Database Search panel highlights the related row in the Peaks Table, and 
the peak in the Chromatogram. 

• The best search match for the MS2 spectrum is displayed as the top hit for each peak retention time. 

The software performs the Dot-Product (Cosine) search to match the MS/MS spectra against the applied 
databases. Using the default settings, the database search results are filtered by: 

• Matching ion polarity using the ion polarity applied in the chromatogram. 

• Precursor ion m/z. 

 
Note: Specific database matches in the Database Search panel will depend on the configured user settings 
and the applied licensed databases available for searching. 
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 Action Result 

4  Go to File > Settings. In the Settings 
dialog that launches, remain on the 
General tab. Ensure that the Filter 
Database Search Results by Precursor 
m/z checkbox is selected, and the value is 
set to “5 ppm”. 

In the Settings dialog that is launched, there are settings for the execution of the cosine similarity search: 

• Match Score Method defines whether HQI or R.HQI (Reverse HQI) should be prioritized. 

o By default, R.HQI is more heavily weighted in LC Expert. 

o The scoring method can be changed using the dropdown menu.  

• Instrument Resolution in accurate mass searches controls the accuracy of the MS/MS search 
matching to a database spectrum. 

• The checkbox (when selected) for Filter Database Search Results by Precursor m/z forces the 
database search results to be filtered by the precursor m/z of the query spectrum: 

o If deselected, query results will not be filtered by precursor m/z and all m/z values will be 
accepted. 

• The checkbox for Set minimum relative peak intensity for query peaks filters peaks below the 
defined height threshold for user data in MS/MS matching. Peaks below the threshold will not be 
matched to a database spectrum. 

• Precursor Ion Tolerance provides the match tolerance for Precursor ion m/z. 
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 Action Result 

5  Click OK in the Settings dialog window to 
close the dialog. Then in the Database 
Search panel, click on the expand icon 

( ) next to a search match. 

The top 10 best matches are displayed (less than 10 matches will populate if <10 spectra were matched 
according to the search settings). Specific matches depend on the configured search settings and the applied 
licensed databases:  

 

Note: Double click on the cell next to the desired row in the Notes column to add a note. 

6  Right click on the Database Search Table 
and select Edit Component Table 
Columns.  

The Column Selection dialog window is launched. 
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 Action Result 

7  Select a column in the Available Columns 
list, e.g., “CAS Registry Number”. Click on 
the Available Column and select Add.  

Click OK to proceed. 

The column is added to the Displayed Columns cell at the bottom of the list. Upon clicking OK, the dialog 
window is closed. The new column is added as a column to the Database Search Table. 

  

Additional columns can be added to the Database Search Table, to add helpful metadata when scanning 
search results. CTRL+F can be used to quickly search the match results. 

8  Go to File > Edit Report Templates to 
import report templates. 

The Report Templates dialog window is launched. If there are templates already in the dialog, skip the next 
step. 

 

9  Click Add then navigate to: 
“C:\Users\Public\Documents\Wiley\ 
KnowItAll\Report Templates\LC Expert”. 

Select all 5 report templates in the folder. 

Click Open. 

The report templates are added to the Available Templates box. 
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 Action Result 

10  Click Close on the dialog window. 

Using the Transfer To ( ) bar, 

click ReportIt ( ).  

 

The Select a Report Template dialog window is launched with the active chromatogram previewed in the 
selected report template. 

 

11  Click to select the “LC_Expert_LC-
MSMS_Landscape” template. Then click 

OK button ( ) on the dialog 
window. 

The Report is generated, displaying the MS/MS search information from the Database Search Table: 

                                                                                                                                                                                                                                                                                   

12  
Use the Back Arrow icon ( ) to return 

to LC Expert. 

LC Expert is active. 
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Example: Targeted Analysis Searching 

This section describes how to perform a targeted analysis search within the chromatogram file. LC Expert’s Targeted Analysis workflow searches 
the chromatogram for a list of compounds in a target list using the exact mass of the targets. 
 

 Action Result 

1  Continue with the Chromatogram from the 
previous section. Click on the Targeted 

Analysis icon ( ) or choose Analysis > 
Targeted Analysis. Navigate to 
“C:\Users\Public\ Public 
Documents\Wiley\KnowItAll\ 
Samples\LC-MS\”. Select 
“Pharmaceutical Compounds.sdbx” and 
click Open. After reading the Target 
Search Results popup, click OK to close 
the popup window. 

 

Note: The sdbx file imports a list of 
compounds as targets to search for in the 
chromatogram. Individual compounds can 
also be searched for by transferring a 
structure from ChemWindow into LC 
Expert using the Transfer To bar. 

Upon selecting the Targets button, a File Explorer window opens. After opening the sdbx file: 

• The Target Search Results popup provides the number of found compounds in the chromatogram. 

 

• The Peaks Table updates with the detected compound information:  

o Annotated Name is the compound record name from the sdbx file. 

o Base Ion [m/z] is the base ion from the MS1 extracted spectrum. 

o Molecular Formula gives the chemical formula for the identified compound (i.e., target). 

o Match Score is the match score calculation using the target’s accurate mass and the 
calculated exact mass. 

o Mass Accuracy is the mass accuracy calculation using the target’s accurate mass and the 
calculated exact mass. 

o Detected Adducts is the adduct which is detected in the extracted spectrum and applied in 
the exact mass calculation. 

o Calculated Mass is the exact mass for the target with the detected adduct. 

o Database Name is the name of the imported sdbx file used as the target list. 

o Record ID is the specific record ID from the sdbx file to identify the detected target. 
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 Action Result 

2  The Peaks Table can be filtered/unfiltered 

by selecting/deselecting the filter icon ( ) 
located on the Standard Toolbar. 

When the filter is selected: 

• The Peaks Table hides any row that does not have a detected target. 

• The Peak Boxes on the Chromatogram are filtered to match the displayed rows in the Peaks Table. 

• The Database Search table will only display matches for peaks visible in the Peaks Table. 
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 Action Result 

3  Select the Transfer To ( ) bar to 

transfer to ReportIt ( ).  

 

The Select a Report Template dialog window is launched: 

 

4  Select “LC_Expert_LC-MS_Landscape” on 
the Select a Report Template dialog 
window. Click OK. 

The Report is generated displaying the accurate mass information from the Peaks Table: 

 

Note: The active display for the Chromatogram will be retained in the report (e.g., filtered versus unfiltered 
chromatogram and tables). 
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 Action Result 

5  
Use the Back Arrow icon ( ) to return to 

LC Expert. 

LC Expert is active. 

6  The Peaks Table can be modified by right 
clicking directly on the table and selecting 
Edit Column Display. 

Click Cancel to close the dialog window. 

The Column Selection dialog window is launched, which allows for hiding columns and rearranging their 
order. 

 

7  The Peaks Table can be copied into a 
document by right clicking on the table and 
selecting Copy to Clipboard. 

The table is copied into a document: 

 

The active display for the Peaks Table will be retained in the report (e.g., filtered versus unfiltered table). 

8  In LC Expert, close the chromatogram file 

by clicking the X icon ( ) on the bottom 
tab. 

 

The chromatogram is closed. 
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Example: Create a User Database for Targeted Analysis Search 

This section describes how to prepare the user database that is used for targeted analysis searching, such as the sample file in the previous 
section. 

 Action Result 

1  To execute targeted analysis searching 
within a Chromatogram, a user database 
with compounds is required for searching.  

Begin by opening the MineIt application 

( ), typically found in the Data toolbox. 

 

The MineIt application is displayed: 

  

2  Create a user database: 

Select Database > New. 

The New Database Creation dialog window is launched. 
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 Action Result 

3  Fill in the required database information: 

• Database File save location. Click 
Browse to select the location and give 
the file a name. 

• Database Name. 

• Database Abbreviation (at least 3 
alphanumeric characters). 

Click OK to proceed. 

A blank database is opened in MineIt: 

  

4  Double click on the Name cell in the first 
blank row of the Table. 

The Property dialog window is launched. 

5  Enter “Amphetamine” in the proceeding 
popup. Press OK to save. 

Amphetamine is displayed as the Name property in the first record (ID 1). 
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 Action Result 

6  Double click in the Structure/Properties 
window where it reads “Double-click to 
edit structure in ChemWindow”. 

ChemWindow is launched as a popout window: 

 

7  Copy the given SMILES string to clipboard: 

c1(ccccc1)CC(N)C 

Then select Edit > Paste Special and 
select SMILES.  

The struture for amphetamine appears in ChemWindow. 

 

8  Click Save to proceed.  The structure is displayed in the MineIt user database: 
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 Action Result 

9  To add the compound’s expected 
Retention Time, navigate to the 
Structure/Properties Table and click Add 

button ( ). 

Type Retention Time in the Property 
dialog window. 

The Retention Time property value appears in the dialog window: 

 

10  Enter the value “3.7” in the Property dialog 
window in the cell next to Value. Retain the 
default units of “min”. Select OK to proceed. 

The Retention Time is added to the record. 

 

Note: Retention Time is not required for the database file. If no value for Retention Time is included, then the 
all time points will be scanned for the compound. 

11  Add more compounds to the database. 
Begin by clicking on the next row in the 
Table. 

Upon clicking on the next row in the Table, it becomes highlighted to depict that it is active: 
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 Action Result 

12  Add the following compounds into the user 
database by repeating steps 4-11. 

 

Name: Methamphetamine 

SMILES:  
c1cccc(c1)C[C@H](C)NC 

Retention Time: 3.85 min 

 

Name: Naltrexone 

SMILES: Provided in the Result cell 

Retention Time: 3.25 min 

Naltrexone SMILES: 
O[C@]12[C@@]3(N(CC[C@@]11C4=C(C(=CC=C4C3)O)O[C@]1(C(CC2)=O)[H])CC1CC1)[H] 

 

Methamphetamine and Naltrexon are added to the database. 

  

This user database of in-house compounds can be used for Exact Mass searching in LC Expert.  

13  Mouse over to the Previous Application 

icon ( ) and click on the down button 

( ). Choose LC Expert to return to the 
selected application. 

 

LC Expert application is active. 
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 Action Result 

14  Using the open raw file icon ( ) located 
in the Standard Toolbar of LC Expert, 
navigate to “C:\Users\Public\Public 
Documents\Wiley\KnowItAll\Samples\LC-
MS\”.  

Open one of the raw Chromatogram files: 

• Compound_1_POS.mzML 

• Compound_2_POS.mzML 

• Compound_3_POS.mzML 

 

The selected Chromatogram opens in LC Expert (e.g., Compound_1_POS.mzML) and deconvolutes: 

  

Note: Specific results in the Database Search Table depend on user settings and databases available in user 
license. 

15  
Click on the Targets icon ( ) or choose 
Analysis > Targeted Analysis.  

Navigate to and select the structure 
database file saved in Step 3 of this section. 
After reading the Target Search Results 
popup, click OK to close the popup window. 

 

One target from the database is found in the chromatogram: 

  

• Amphetamine is detected in “Compound_1_POS.mzML”. 

• Methamphetamine is detected in “Compound_2_POS.mzML”. 

• Naltrexone is detected in “Compound_3_POS.mzML”. 
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 Action Result 

16  Note: User settings for Targeted Analysis 
can be updated by selecting File > Settings 
and choosing the Target Analysis tab.  

The available Targeted Analysis settings are: 

• Mass Tolerance for accurate mass deviation tolerance.  

• Retention Time Threshold for the retention time tolerance in seconds. 

o Match Retention Times checkbox turns this setting on/off. 

• Hide Target Search Results checkbox prevents the Targets Search Results popup from appearing 
when selected. 

• Mass Adducts Databases allows the user to import additional adducts in an sdbx file, to be used in 
the targeted analysis search. 

o By default, only [M+H] or [M-H] adducts are scanned for in the Chromatogram. 

o To add additional adducts, click the Browse to Add button and navigate to “Additional 
Adducts.sdbx” found in the LC-MS samples folder (see next step for more information). 

  

17  Note: Users can create their own adduct 
libraries by modifying the sample sdbx file 
“Additional Adducts.sdbx” from the LC-
MS samples folder 
(“C:\Users\Public\Public 
Documents\Wiley\KnowItAll\Samples\LC-
MS\”), or by creating their own database file 
following the standards provided in this 
sample file. 

 

To prepare an adduct library, the following information is required: 

• Name: used for adduct labels. 

• Formula: used to calculated the isotopic adduct radio. 

o KnowItAll has been designed to recognize adduct losses by incorporation of a subtraction (-) 
symbol, e.g., adduct [M-H] is be depicted as -H, and adduct [M+Cl-H] is depicted as Cl-H.  

• Selected Ion Charge: gives the ion charge and polarity where the adduct should be scanned. 

o E.g., The adducts [M-H] and [M+Cl-H] should be -1 and -2 correspondingly. 

o Positive ions do not need a plus (+) symbol because the adduct is assumed to be positive 
(unless specified with a – symbol, denoting a negative adduct). 
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Example: Manual Deconvolution 

In some cases, a user may prefer to perform their own peak selection for deconvolution, which can be performed using LC Expert’s manual 
analysis method. 
  

 Action Result 

1  Begin by opening an LC-MS 
chromatogram file in LC Expert. This 
example will use 
“TESTMIX2_180504_MAS011_06 
.mzXML” located in 
“C:\Users\Public\Public 
Documents\Wiley\KnowItAll\Samples\L
C-MS\”. 

The chromatogram opens in LC Expert application. The Analysis Method is visible on the Standard 
Toolbar, and is set to the last applied method: 
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 Action Result 

2  Using the Analysis Method dropdown 
menu on the Standard Toolbar, select 
Manual. 

 

LC Expert enters Manual mode: 

• All previously deconvoluted peaks become cleared from the Peaks Table and Database Search 
Table. 

• The Average Range Bar appears below the Chromatogram panel. Use this to select a series of MS 
scans to be averaged as the analysis region. 

• The Background Range Bar appears above the Chromatogram panel. Use this to select a 
background region to subtract from the analysis region. 
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 Action Result 

3  On the chromatogram, navigate to a 
desirable peak for analysis. Using the 
Average Range Bar, click the left mouse 
button down and drag horizontally down the 
bar to select a region across a peak. 
Release the mouse button to accept the 
region. 

An analysis region is highlighted using blue coloration on the Chromatogram. An extracted MS spectrum is 
created across the selected region. Additionally, if the region contains MS/MS scans, then an average of the 
MS/MS scans will be searched in the libraries and populate in the Database Search Table: 

 

Note: To search a single MS/MS scan instead of an average, do not select a region using the Average Range 
Bar. Instead, click directly on the chromatogram to choose a single timepoint for searching. 
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 Action Result 

4  On the chromatogram, navigate to a 
desirable baseline region to represent the 
background. Using the Background Range 
Bar, click the left mouse button down on the 
and drag horizontally down the bar to select 
a region. Release the mouse button to 
accept the region. 

A background region is highlighted using red coloration on the Chromatogram, representing the baseline to 
subtract from the analysis region. The search results in the Database Search Table will refresh according to 
the updated region selection. 

 

5  Note: LC Expert will retain the last used 
Analysis Method. To prepare for future 
steps in this documentation, change the 
Analysis Method back to Deconvolution. 

 

The chromatogram becomes automatically deconvoluted, as seen in Step 1 of this section. 
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Training Files Used in This Lesson 

• Folder files in 
C:\Users\Public\Documents\Wiley\KnowItAll\Sa
mples\LC-MS 

KnowItAll Applications Used 

• KnowItAll LC Expert 

• KnowItAll SearchIt 

• KnowItAll MineIt 

LC-MS/MS Spectrum Searching Methods 
How to use KnowItAll SearchIt to Apply Advanced Algorithms for Spectrum Searching 

 

Purpose 
 
These exercises demonstrate how to use KnowItAll SearchIt to tune search methods for single MS/MS spectral searches. 
 

Objectives 

 
These exercises will teach you how to: 

➢ Apply MSforID search algorithm 

➢ Single spectrum search methods: Adaptive Search, Precursor Ion Filtering 

➢ Use Peak m/z Search method when searching computed libraries 

 

Background 

KnowItAll has vast tools for LC-MS/MS spectral searches. In addition to the deconvolution tools in 

LC Expert, users can search single spectra in SearchIt application. Here they gain access to even 

more search algorithms and search controls. This includes MSforID search algorithm for high 

accuracy LC-MS searching, patented adaptive searching, tools for precursor ion filtering, and more. 
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MSforID Searching 

Introduction to MSforID Searching 
The many challenges for preparing tandem MS search libraries and algorithms for unknown compound identification are well known and documented. 
Nonetheless, search tools and databases remain a critical part of the tandem MS workflow. The MSforID search method was designed to address these 
challenges, such as demonstrating a robustness against instrumental variability when searching quality databases and a high tolerance to variability in peak 
fragmentation patterns (i.e., between the correct database match versus its experimental spectrum).3 MSforID was positively evaluated using different instruments 
(e.g., QqTOF, QqLIT, QqQ, LIT, LIT-FTICR and QTRAP) by different manufacturers and in different laboratories.2-4 
 
The approach for MSforID searching is to compare the search query against a library of compounds where multiple CID spectra exist for each compound record. 
The compound records contain multiple spectra measured at different collision energies creating the series of spectra for the compound. The MSforID search 
algorithm then compares the query spectra to the series of CID spectra for the compound (Figure A). This is dissimilar to typical databases search algorithms that 
compare the query to a single spectrum per match (Figure B).  

 

 

 

 
Figure A) MSforID and B) NIST MS Search identify search methods. (Reprinted from Ref. 3) 

The MSforID Algorithm 
The MSforID algorithm measures the average similarity of a query spectrum to the series of compound reference spectra. It is a probability-based matching 
algorithm that analyzes: 

• The mass deviation for the precursor ion between the query spectrum and the database compound record. 

• The number of matching fragments between the query and the database spectrum. 

• The mass deviations and intensity differences for matching fragments. 

For each search result, the algorithm calculates the Average Match Probability (AMP) for the compound’s database record that contains the series of spectra. 
The Relative Average Match Probability (RAMP) is subsequently calculated, which is the normalized AMP value compared to the search results for the specific 
query (i.e., from 0-100).3 Search results are presented in KnowItAll’s MineIt by descending RAMP values, and the highest RAMP value is considered the best 
match. A RAMP value of >40.0 is considered a very good match score.5 
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Using the MSforID Search Tool in KnowItAll 
Three search methods are available for MSforID searching in KnowItAll’s SearchIt application: (1) Standard Search (default), (2) Composite Search, and (3) 
Direct Search. The recommended search algorithm is the Standard Search, which applies the main published algorithm.3 The Standard Search compares all 
spectra in the database record to the query spectrum (as in Figure A) to compute the RAMP. Differently, the Composite Search compares the single averaged 
spectrum for all spectra in the database record to the query spectrum using an adapted version of the MSforID algorithm. The averaged spectrum is calculated in 
real-time during the search, and the Composite Search can be faster when using very large databases. The Direct Search is a revised edition of the MSforID 
algorithm that aims to remove false positives from the hitlist.  

Preparing In-House MSforID Libraries 
The “Wiley Registry of Tandem Mass Spectral Data – MS for ID” database contains highly curated spectra for use with MSforID searching in SearchIt. To prepare 
user libraries in-house that are highly curated for accurate MSforID searching, the MSforID database standards1 are recommended: 

1. Measure mass spectra for the standard compounds at multiple collision energies (e.g., from 5 to 50 eV). 
2. Filter low abundant signals in the standard spectra (e.g., less than 0.01%). 
3. Prepare database records in MineIt using one precursor ion (e.g., M+H). If compound spectra detected from different adducts are available for your 

library, separate these out into different records (e.g., M+H spectra in one record and M+Na spectra in a second record). 

References & Additional Reading on MSforID 
1. M. Pavlic, K. Libiseller, H. Oberacher. Combined use of ESI-QqTOF-MS and ESI-QqTOF-MS/MS with mass-spectral library search for qualitative analysis 

of drugs. Anal. Bioanal. Chem. 2006, 386, 62-82. doi: 10.1007/s00216-006-0634-8 
2. H. Oberacher, M. Pavlic, K. Libiseller, B. Schubert, M. Sulyok, R. Schuhmacher, E. Csaszar, H. Köfeler. On the inter-instrument and the inter-laboratory 

transferability of a tandem mass spectral reference library: 1. Results of an Austrian multicenter study. J. Mass Spectrom. 2008, 44, 485-493. doi: 
10.1002/jms.1545 

3. H. Oberacher, M. Pavlic, K. Libiseller, B. Schubert, M. Sulyok, R. Schuhmacher, E. Csaszar, H. Köfeler. On the inter-instrument and the inter-laboratory 
transferability of a tandem mass spectral reference library: 2. Optimization and characterization of the search algorithm. J. Mass Spectrom. 2008, 44, 494-
502. doi: 10.1002/jms.1525 

4. H. Oberacher, W. Weinmann, S. Dresen. Quality evaluation of tandem mass spectral libraries. Anal. Bioanal. Chem. 2011, 400, 2641-2648. doi: 
10.1007/s00216-010-4598-3 

5. H. Oberacher, G. Whitley, B. Berger, W. Weinmann. Testing an alternative search algorithm for compound identification with the ‘Wiley Registry of 
Tandem Spectral Data, MSforID’. J. Mass Spectrom. 2013, 48, 497-504. doi: 10.1002/jms.3185  

https://sciencesolutions.wiley.com/solutions/technique/lc-ms/wiley-registry-of-tandem-mass-spectral-data-ms-for-id/
https://link.springer.com/article/10.1007/s00216-006-0634-8
https://analyticalsciencejournals.onlinelibrary.wiley.com/doi/full/10.1002/jms.1545
https://analyticalsciencejournals.onlinelibrary.wiley.com/doi/full/10.1002/jms.1525
https://link.springer.com/article/10.1007/s00216-010-4598-3
https://analyticalsciencejournals.onlinelibrary.wiley.com/doi/10.1002/jms.3185
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Example: MSforID Search 

This section describes how to execute an MS/MS library search using the MSforID search algorithm using the SearchIt application. 
 

 Action Result 

1  Using the Open Raw LC-MS Data File icon 

( ) located on the Standard Toolbar in 
LC Expert, navigate to 
“C:\Users\Public\Public 
Documents\Wiley\KnowItAll\Samples\LC-
MS\”.  

Open “TESTMIX2_180504_MAS011_06 
.mzXML” (C:\Users\Public\Public 
Documents\Wiley\KnowItAll\Samples\LC-
MS\). 

The Chromatogram opens in LC Expert and deconvolutes: 

  

2  Click in the Peaks Table on the row with 
RT equal 8.93 min to select the peak (i.e., 
row 18 using default deconvolution 
settings). 

The peak at 8.93 min becomes selected in the Chromatogram: 
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 Action Result 

3  
On the Transfer to bar ( ), 

select SearchIt ( ). 

The Import of Multiple Spectra dialog window appears. The “MS Level 2 Raw Spectrum” option is selected by 
default: 

 

Note: This dialog is used to specify which MS spectral scan will be transferred using the Transfer to bar. 

4  On the Import of Multiple Spectra 
dialog window, retain the default 
selection “MS Level 2 Raw Spectrum”.  

Select OK to continue. 

The SearchIt import dialog window appears with 2 different search options: 

• “MSForID”, to open a new MSforID search tab in SearchIt. 

• “Spectrum Search”, to use an alternative search algorithm (e.g., cosine, adaptive search, partial 
spectrum search, etc.). 

 

 
 



  

108658-REV20250822 Copyright ©2025 by John Wiley & Sons, Inc. All rights reserved. 

KnowItAll Training                                                                                                        LC Expert 36 

 Action Result 

5  Select MSforID on the SearchIt dialog 
window. 

 

Note: If desired, the volume of peaks 
included in the search can be modified 
using the Intensity Threshold (%) 
setting. Select Repick Peaks button 

( ) to update the Peaks to 
Search list using the updated threshold. 

The triangle symbol ( ) reveals the 
minimum peak height.  

The MS2 raw spectrum opens in SearchIt’s MSforID Search window. The MSforID Search window 
prepopulates the information: 

• Ion Polarity which is the ion polarity information in the raw chromatogram file, if included in the raw file. 

o If this information is not included in the raw file, then positive will be selected by default, and 
this could be updated to negative by selecting the opposite radio button. 

• Search Method is the specific MSforID Algorithm that will be applied in the search. The last use 
search will be selected as the menu option. 

o Standard Search (default) 

o Composite Search 

o Direct Search  

• Precursor Ion (m/z) is the MS2 scan’s precursor ion information, if included in the raw file. 

• Mass Tolerance (m/z) parameter sets the tolerance for MS spectrum peak m/z deviations. 

• Intensity Threshold (%) parameter sets the minimum peak height for the MS spectrum peaks. 

 

Note: A popup will display on the Warning dialog window if the raw spectrum is not detected to be an MS2 
spectrum. This could be because the raw file does not contain MS Level information (e.g., such as imported .jdx 
files), or it is the wrong MS Level (e.g., MS Level = 1). Click Confirm to bypass the warning and import the MS 
spectrum into the window or Cancel to stop the process. 
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 Action Result 

6  In the MSforID Search window, change 
the Mass Tolerance value to “0.01" m/z. 

The Mass Tolerance is decreased: 

 

Note: The Mass Tolerance value plays an impactful role in the calculation and final search results. 

7  Under the Search Databases section, 
click on User-Select option. 

 

Next to Limit to spectral technique 
option, choose MS (LC) using the 
dropdown menu. 

 

Then select databases for searching 
using by clicking on the specific database 
row in the database list, followed by the 

Add button ( ). 

The databases selection dialog window is displayed. In the example below, all available LC-MS databases were 
added to Selected for Searching section.  

 

Note: Available LC-MS databases depend on the specific user license. 

 
 
 
 
 
 
 
 
 
 
 



  

108658-REV20250822 Copyright ©2025 by John Wiley & Sons, Inc. All rights reserved. 

KnowItAll Training                                                                                                        LC Expert 38 

 Action Result 

8  
Select Search button ( ) to 
execute the search.  

The best match for the spectrum query is displayed in MineIt. The Table displays the columns: 

• AMP (Average Match Probability), which is the average probability that the reference compound 
record could be the query spectrum. 

• RAMP (Relative Average Match Probability), which is the AMP value relative to the total search 
results. 

o By default, the search results will be organized by decreasing RAMP value. 

• Precursor Ion m/z Difference which is the m/z difference between the query’s precursor ion and the 
database record. 

 

Note: Each row in the search results Table represents a match for the compound record’s series of spectra, 
and each compound record can only be returned once as a match result. In the Table, each compound 
record’s MS spectra will retain the order in which they exist in the database, i.e., the first spectrum in the series 
will always be displayed first in the search results. 
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 Action Result 

9  Navigate to the Previous Application 

icon and click on the down button ( ). 
Choose LC Expert to return to the 
selected application. 

 

LC Expert application is active. 
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Example: Spectrum MS/MS Searches using SearchIt  

This section describes how to execute an MS/MS library search using spectral search algorithms in SearchIt application: spectrum search and 
patented adaptive searching. 
 

 Action Result 

1  Continue with the Chromatogram from 
the last section. In LC Expert, with the 
scan from the previous Step 2 still 
selected, use the Transfer to bar 

( ) to send the spectrum to 

SearchIt ( ). 

The Import of Multiple Spectra dialog window appears. The “MS Level 2 Raw Spectrum” option is selected by 
default: 

 

Note: This dialog is used to denote which MS spectral scan should be transferred using the Transfer to bar. 

2  On the Import of Multiple Spectra 
dialog window, retain the default 
selection “MS Level 2 Raw Spectrum”. 
Select OK to continue. 

 

The SearchIt import dialog window appears with 3 different search options: 

• “Replace existing MSforID search”, to override an existing search in SearchIt.  

• “Open MSforID in new document”, to open a new search window in SearchIt. 

• “Open spectrum search in new document”, to use an alternative search algorithm (e.g., cosine, adaptive, 
etc.). 
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 Action Result 

3  Select “Open spectrum search in new 
document”. 

 

The MS2 raw spectrum opens in SearchIt’s Spectrum Search dialog window. SearchIt recognizes that the 
spectrum search type is LC-MS and is labelled as Spectrum MS (LC): 

 

For further control of the spectrum search: 

• Include Range Bar and Exclude Range Bar allow for including/excluding specified areas on the 
spectrum. 

• Search Method allows for changing the search algorithm, such as from Dot-Product (Cosine) to Peak 
m/z Search (which is further described in a later section). 

4  In the Spectrum MS (LC) window, select 
the checkbox next to Accurate Mass 
Search and Filter by Precursor m/z. 

 

 

Accurate Mass Search is selected: 

  

• Accurate Mass Search retains high resolution information included in the spectrum query and 
database record when performing the search. 

• Filter by Precursor m/z will filter the database search results by the precursor ion information from the 
raw spectrum. 

Note: Click Advanced Settings button ( ) to modify the Precursor Ion Tolerance and 
Instrument Resolution settings for Accurate Mass searches. 
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 Action Result 

5  Under the Search Databases section, 
click on User-Select option. 

 

Next to Limit to spectral technique 
option, choose MS (LC) using the 
dropdown menu. 

 

Then select databases for searching 
using by clicking on the specific database 
row in the database list, followed by the 

Add button ( ). 

The databases selection dialog window is displayed. In the example below, all available LC-MS databases were 
added to Selected for Searching section.  

 

Note: Available LC-MS databases depend on the specific user license. 

6  Click Search to execute.  The best match for the spectrum query is displayed in MineIt:  
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 Action Result 

7  Use the Previous Application arrow 

( ) to return to SearchIt. 

SearchIt application is opened with the previous query loaded. 

8  Click on Spectrum MS (LC) to modify 
the spectrum search settings.  

 

Select the Adaptive Search checkbox. 

The Adaptive Search is selected, and the Filter by Precursor m/z checkbox becomes deselected: 

 

Adaptive Search method allows for scanning the spectrum peaks for available functional groups or molecular 
replacements between the query spectrum and the database spectrum, extending the database library to similar 
compounds that are not in the available spectral space. 

Note: Adaptive Search method is available for low resolution data by deselecting the Accurate Mass Search 
checkbox. 

9  Click Search to execute. The best match for the spectral query is displayed in MineIt: 

 

For the Adaptive Search results, regarding the spectrum query and the database record: 

• Δm column gives the difference in compound mass between the query and the database compound. 

• Δm info column contains a selectable info icon ( ) that informs on the peak shifts that occurred to 
create the query result. 

• Replacement column gives the group replacement if known. 
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Example: Peak m/z Search Method 

This section describes how to more effectively search computed libraries using Peak m/z Search algorithm. This algorithm matches the most 
intense peaks from query spectra to database records by Exact Mass independently of the peak intensity. This algorithm is recommended for use 
with Computed Libraries, where many of the database records are MS spectra with peaks at 100% intensity. 
 

 Action Result 

1  Open a LC-MS chromatogram file in LC 
Expert.  

 

The chromatogram opens in LC Expert: 

 

The example chromatogram above is a file featuring Lipids. 

2  Choose File > Settings. The Settings dialog is launched: 
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 Action Result 

3  Remain on the General tab. Change 
the Database Search Algorithm to 
Peak m/z Search using the dropdown 
menu. 

 

Peak m/z Search algorithm is selected in the dialog: 

 

 

Note: Confirm that the checkbox for Set minimum relative peak intensity for query peaks is selected. When 
turned on, query peaks below the minimum threshold will not be matched to database spectra. 

 

4  On the Settings dialog, click OK button 

( ) to accept the changes. 

The Database Search Table will refresh the search matches according to the changed algorithm.  

 

 
 
 
 
 



  

108658-REV20250822 Copyright ©2025 by John Wiley & Sons, Inc. All rights reserved. 

KnowItAll Training                                                                                                        LC Expert 46 

 Action Result 

5  Note: The Peak m/z Search algorithm 
is also available in SearchIt. To apply, 
follow instructions for a spectrum 
search in section “Spectrum MS/MS 
Searches using SearchIt” and change 
the Search Method to Peak m/z 
Search using the dropdown menu. 

 

In SearchIt’s Spectrum Search interface, Peak m/z Search is selected as the search algorithm: 
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Training Files Used in This Lesson 

• N/A 

KnowItAll Applications Used 

• KnowItAll LC Expert 

Batch LC-MS Processing 
How to use KnowItAll LC Expert to Perform Automatic LC-MS Component Identifications 

 

Purpose 
 
This exercise demonstrates how to use KnowItAll LC Expert to process and analyze a series of raw LC-MS chromatograms.  
 

Objectives 

 
These exercises will teach you how to: 

➢ Use KnowItAll LC Expert project mode to process a folder of raw chromatograms 

 

Background 

Analyzing raw chromatograms can be a time-consuming process, especially if multiple runs of 

similar samples are acquired. KnowItAll’s LC Expert in project mode allows users to process, align, 

and identify folders of files in a single submission, then review result summaries as a project file. 
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Example: Batch LC-MS Processing 

Batch LC-MS processing can be used when a series of related chromatographic samples were acquired. If the samples are not related, then the 
singular processing workflow should be applied. 
 

 Action Result 

1  Open LC Expert. LC Expert application is displayed with no files previously opened: 

 

2  Click the New LC-MS Data Project 
button.  

 

The Batch Processing dialog window appears on Step 1: Select raw chromatograms for processing step: 

 

This dialog is used to enter details for batch processing of file folder. 
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 Action Result 

3  Using the popup dialog window, enter 
the following details: 

• Project Name: a name for the 
project file 

• Save Location: click Browse 
button to choose the output file 
location 

• Raw Chromatogram Folder: click 
Browse button to choose the input 
LC-MS file folder 

Project details have been filled out to give the project file a name, output location, and input file location: 

 

4  In the section Export Project Files, 
choose exportation settings for the 
individual chromatogram files. Decide if 
individual chromatogram tables should 
be exported as csv: 

• The checkbox for Export 
Database Search Table As CSV 
exports a Database Search Table 
per chromatogram file. 

• The checkbox for Export Peak 
Table As CSV exports a Peaks 
Tables per chromatogram file. 

For each submitted project, a project file will be generated (.lcp) file that summarizes the aligned picked peaks for 
the series of chromatograms. Each individual chromatogram file will be saved as a file (.lca) to enable post-
processing review. Additionally, the checkboxes in the Export Project Files section will export the corresponding 
tables (.csv) for the individual chromatogram files. 
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5  In the section Peak Identification, 
choose component identification 
requirements. 

• The checkbox for Perform tandem 
MS database search will require 
the deconvoluted peaks to be 
searched in the LC-MS libraries. 

• The checkbox for Perform 
Targeted Analysis search allows 
for attaching a Targeted List as 
.sdbx file for target identification. 
See training section “Create a User 
Database for Targeted Analysis 
Searching” for more information on 
library preparation. 

The configured settings below enable component identification. Note: Specific database search settings are 
controlled at a subsequent step in the dialog. For the series of chromatogram files, when performing an MS/MS 
database search and/or targeted analysis search, the component with the highest match score according to the 
specific algorithm will be reported as the identified component in the sumary project file. 

 

6  Click Next > button to proceed in the 
dialog.  

 

Step 2: Determine processing settings is displayed on the dialog. Here, specific chromatogram processing and 
database matching controls are submitted: 
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7  The dialog section Chromatogram Ion 
Mode allows for overriding the 
automatic detection of the ion mode.  

Automatic Detection selection is retained: 

 

Note: This control could be used for control if the chromatogram files contain both ion modes. 

8  The dialog section Peak Picking 
Settings enables attaching of an 
Analysis Profile. 

Note: An Analysis Profile is not 
required. Choose “None” to bypass. 
For more information on how to create 
an Analysis Profile, follow the next 
step (otherwise bypass it). 

An Analysis Profile is attached to the dialog. The Analysis Profile gives user control over: 

• Peak deconvolution settings 

• Applied peak picking algorithm (Dot Product (Cosine) or Peak m/z Search) 

• Applied LC-MS databases for searching 

• Precursor ion filtering 

If no Analysis Profile is attached, then the last used settings in LC Expert (under File>Settings) will be applied.  

 

 

9  Note: To create an Analysis Profile, 
follow these steps:  

• Open a single chromatogram in LC 
Expert. 

• Apply the desired settings (in the 
Settings dialog and the 
Deconvolution Settings panel). 

• On the Standard Toobar, select 
the Save Current Profile icon 

( ) and give the Analysis 
Profile file a name. 

When an Analysis Profile is saved in LC Expert, it will automatically appear in the Analysis Profile section of the 
Batch Processing dialog without additional attachment requirements. 
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 Action Result 

10  The dialog section Peak Alignment 
Settings enables control over the 
tolerances for alignment:  

• Mass Tolerance controls the 
amount of allowed deviation for the 
m/z value. 

• Retention Time Threshold 
controls the amount of deviation for 
the RT value. 

The Peak Alignment settings are defined: 

 

11  Click Next > button to proceed in the 
dialog.  

 

Step 3: Select time region for analysis is displayed on the dialog. The preview window displays the first 
chromatogram in the folder of files selected for processing.: 
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 Action Result 

12  Using the Include Range Bar on the 
dialog, click the left mouse button down 
and drag across the bar horizontally to 
select a time region. Release button to 
accept the region. 

 

Note: The end boundaries can be 
changed by clicking on the end of the 
selected region with the left mouse 
button and dragging to a new time 
point. Use the trashcan icon to remove 

selection entirely ( ). 

The region for analysis is selected: 

 

The analysis region by time is defined for the batch processing. If no region is selected, then the entire 
chromatogram will be processed.  

13  Click Next > button to proceed in the 
dialog.  

 

Step 4: Data Processing is displayed on the dialog. Now the chromatograms are submitted for batch processing: 

• A Progress Bar applies green coloration to visualize the progress of the batch processing. 

• A Log is reported in the white box to define the active step of the batch processing. 
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 Action Result 

14  Allow the batch processing to run to 
completion. 

 

Note: If the process needs to be 
aborted, click Cancel button 

( ) on the dialog. 

When batch processing is complete, the dialog Log reads “Data processing finished successfully” and the 
Progress Bar is entirely green. 

 

15  
Click Finish button ( ) on 
the dialog to close the dialog. 

The project file (.lcp) automatically opens in LC Expert: 
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 Action Result 

16  Analyze the .lcp file results. 

 

Note: The Database Match Structure 
can be visualized directly in the project 
file. Choose View > Match Structure 
in Pane.   

 

 

The .lcp file summarizes the results of the batch processing: 

• RT [min] column gives the aligned peak retention time for the samples. 

• Base Ion [m/z] column is the detected base ion representing the aligned peak. 

• Files column gives the names of all the files for which the peak was identified in then aligned. 

If Database Searching was applied at Step 1 (otherwise, these columns will not appear): 

• Database Match gives the highest database match for the peak component. 

• Score gives the match score for the Database Match. 

• Database Match Reference File reports the file for which the highest Database Match was detected in. 

If Targeted Analysis Searching was applied at Step 1 (otherwise, these columns will not appear): 

• Target Match gives the highest match from the target list for the peak component. 

• Match Score gives the match score for the Target Match. 

• Target Match Reference File reports the file for which the highest Target Match was detected in. 

• Mass Accuracy, Detected Adducts, Mass Accuracy, Calculated Mass, Adducts Accurate Mass, 
Database Name, and Record ID are determined from the Target Match, and specific definitions are given 
in section “Targeted Analysis Searching” of this document. 

 

Below, the database Match Structure is visualized using the selected pane: 
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 Action Result 

17  Note: All project files are saved at the 
selected file location from Step 1. 

At the described file location, there will be: 

• The .lcp file for the project which allows for reviewing the results. 

• An .lca file for each processed chromatogram, which allows for individual review of processed 
chromatogram files. 

• Any peaks selected for exporting as csv. 

 

 


