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Training Files Used in This Lesson 
In C:\Users\Public\Documents\Wiley\KnowItAll\Samples folder 

• \MS\1,1,1-Trichlorobutane - Adaptive Search demo 
• \MS\2-Hydroxybenzoic acid 
• \Mixture Analysis\MS Examples\MS Mixture of Two 1 
• \Mixture Analysis\MS Examples\MS Mixture of Two 2 
• \Mixture Analysis\MS Examples\MS Mixture of Three 
• \GC-MS\Barbiturate GC-MS.d 
• \Mixture Analysis\MS Examples\Components.SDBX 

KnowItAll Applications Used 
• SearchIt  
• MineIt  

 

Mass Spectrometry Spectral Searching 
How to Perform a Mass Spectrometry Spectral Search 

 
Purpose 
 
This exercise demonstrates how to perform a mass spectrometry spectral search.  
 

Objectives 
 
This exercise will teach you: 

 How to perform a straightforward search 

 How to perform a reverse search 

 How to complete a mixture analysis 

 How to perform an adaptive search (similar compound search)  

 How to perform simultaneous multiple MS spectra search 
 

Background 
 
Spectral searching against reference databases is frequently used in the 
analysis of unknown compounds. KnowItAll has full-featured MS spectrum 
comparison tools for this purpose. 
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Algorithms 

 
 

 
 
 
A. Samokhin, K. Sotnezova, V. Lashin, I. Revelsky. Evaluation of mass spectral library search algorithms implemented in commercial software. 
Journal of Mass Spectrometry. 2015, 50, 820-825. 
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Search Methods: 

• Dot-Product (Cosine): second equation in above figure 
• Wiley Dot-Product (Cosine): the Finnigan algorithm that verified at least 12 of the largest 16 peaks and the base peak match before 

continuing with the dot-product calculation   
• Composite P1: first equation in above figure 
• Composite P3: first equation in above figure 

P1 and P3 are different by the power applied to the weighted intensity of peak. 
 
Optimized Corrections: 

• Mass Defection is the difference between a compound's exact mass and its nominal mass. It is automatically applied for a MS search.  
Examples: 

o For hydrocarbon compounds, when m/z value is over 500, use 0.99888. 
o For polybrominated compounds, when there are more than 5 Br atoms and m/z value is over 800, use 1.00087. 

• Spectral Skewing is caused by analyte’s concentration changing during scan. A linear compensation factor (positive for ascending or 
negative for descending slope) is calculated for each search match. This factor corrects the intensities as follows: 

I(corrected)=I * f * m,  

where I=intensity, f=OC factor, and m=m/z value 
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Straightforward Search 
 Action Result 

1 Open the KnowItAll SearchIt application by 
clicking its icon in the KnowItAll application. 

Check Spectrum and navigate to 
C:\Users\Public\Documents\Wiley\KnowIt
All\Samples\MS folder. 

Select the file 2-Hydroxybenzoic acid. 

Click Open. 

Ensure Adaptive Search or Reverse 
Search is unchecked. 

 

Note: Since the KnowItAll 2025 release, one can perform accurate mass search in addition to 
the default unit mass search (check highlighted box above). 



  

108658-REV20250813  Copyright ©2025 by John Wiley & Sons, Inc. All rights reserved.  

KnowItAll Training   Mass Spectrometry - 6 

 Action Result 

2 Click User-Select. 

 

Use Remove All to clean selected 
databases. 

 

Use Limit to spectral technique to select 
MS (GC). 

 

Use Add All to add all MS (GC) databases. 

 

Click Search. 

 

After selecting Add All for the MS (GC) databases, the full GC-MS database collection is 
selected for searching: 
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 Action Result 

3 Click the Butterfly view icon  to place the 
unknown and reference spectrum in the 
opposite Y-direction. 

A target from a database is found: 

 

Hits are initially sorted by the Hit Quality Index (HQI). Reverse Hit Quality Index (R.HQI) is 
also calculated for each reference spectrum. 
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 Action Result 

4 Note: HQI (Hit Quality Index) The HQI value measures how close the reference spectrum is to that of the query. The default 
scale of HQI is 0-100. You can change the scale from MineIt > File > Preferences > Hit List. 

 

Note: Reverse Search ignores peaks that are in unknown but not in reference. One scenario is 
that the unknown spectrum might be a mixture and the reference spectrum might be a 
component. 
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Note: One can view the metadata of query spectrum by 

• View > Query Spectrum Info   in SearchIt and  
 

 

• View > Windows/Tables > Query Spectrum Info  in a MineIt hit list. 
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Optimized Corrections 
 Action Result 

1 Go back to SearchIt. 

Click  to start a new search.  

Click Spectrum and navigate to 
C:\Users\Public\Documents\Wiley\KnowIt
All\Samples\MS. 

Select the file Mass defect correction 
example.ms. Click Open. 

Click OK (use the default MS 17108). 

Upon selecting the Mass defect correction example.ms, the MS Spectrum Selection dialog 
appears to prompt for spectrum import selection: 
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 Action Result 

2 Optimized Corrections for MS spectrum is 
the default to be checked. 

 

Click Advanced Setting button. 

 

Click OK to close this dialog. 

 

Click the Search button. 

 

One can see that Mass Defection Correction (the difference between a compound's exact 
mass and its nominal mass) is automatically applied. Many other criterion, such as Spectral 
Skewing (analyte’s concentration changing during scan), can be applied by users choice to 
improve a search. 

 

https://www.sciencedirect.com/topics/chemistry/analytes
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 Action Result 

3 View the search results. 

 

We can see analyte MS and reference MS are perfectly aligned at m/z 662. 

4 Go back to SearchIt. 

Check off Optimized Corrections. 

 

Search again. 

 

 

At high m/z range, analyte peaks and reference peaks are not aligned nicely. 
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Combined Retention Index (RI) Search 
In KnowItAll 2026 release, you can add RI search to the MS spectral search.  When a MS spectrum is read in SearchIt, the RI Constraints check 

shows up:   
 

Open this box, select a RI field and enter the value range.  
 

Partial MS Search 
Also new in KnowItAll 2026, you can choose the MS partial spectrum search.  

• The partial spectrum search HQI (P.HQI) will not penalize peaks that are found in the database spectrum but not in the query. 
• Partial spectrum search and reverse search cannot be used together.  
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Reverse Search  
This search ignores peaks that are in unknown but not in reference. 
 
 Action Result 

1 Go back to SearchIt. 

Click  to start a new search.  

Click Spectrum and navigate to 
C:\Users\Public\Documents\Wiley\KnowIt
All\Samples\Mixture Analysis\MS 
Examples folder. 

Select MS Mixture of Two 1 to open. 

Check Reverse Search. 

 

  



  

108658-REV20250813  Copyright ©2025 by John Wiley & Sons, Inc. All rights reserved.  

KnowItAll Training   Mass Spectrometry - 15 

 Action Result 

2 Click User-Select button. 

 

Use button Remove All to clean current 
database selection. 

 

Then, use Select by Browsing button to 
add the example database:  
C:\Users\Public\Documents\Wiley\KnowIt
All\Samples\Mixture Analysis\MS 
Examples\Components.SDBX. 

Click Search. 
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 Action Result 

3 In MineIt, make sure that Subtract View 
(circled) is selected.   

In the spectrum pane, the first row is the 
unknown, the last row is the reference 
spectrum, and the middle row is the 
difference between the two.   
 

 

The hits are initially sorted by the Reverse Search HQI (R.HQI). 
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 Action Result 

4 Transfer spectra in spectrum pane to 
SearchIt using the Transfer to: menu at the 
top of the application. 

 

Select to transfer only the Difference 
Spectrum. Click OK. 

When prompted by SearchIt, choose Start a 
new search. 

 

Upon transferring the Difference Spectrum to SearchIt, the Import of Multiple Spectra 
dialog is prompted: 
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 Action Result 

5 Click Search. 
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 Action Result 

6 Analyze the search results in MineIt. 

 

A second component is identified. 

Notice that the Difference Spectrum is empty, which means there are no more components. 
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Mixture Analysis 
A mixture wherein two-component MS spectra have limited overlap, and one of them has a large MS range. 
 

 Action Result 

1 Go back to SearchIt. 

Start a new search by clicking . 

Select MS Mixture of Two 1. 

 

Ensure Reverse Search or Adaptive 
Search is unchecked. 

Use the drop-down menu to set the 
Number of components to 2.  
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 Action Result 

2 Click on User-Select. 

 

Make sure Components database is 
selected to use. 

Click Search. 
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 Action Result 

3 Analyze the search results in MineIt. 

 

KnowItAll presents a 2-component search result. The top spectrum is unknown; the bottom 
spectrum is the composite spectrum of 2 components. The middle spectrum is the difference 
between the two. In this case, it is next to nothing, indicating that there are no more residual 
peaks. 

Note: This is an example wherein the two-component MS spectra have limited overlap, but 
one of them has large MS range. 
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A more complex example 
 Action Result 

1 Go back to SearchIt. 

Start a new search by clicking . 

Select the file MS Mixture of Three. 

Use the drop-down menu to set the 
Number of components to 3 (Mixture). 
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 Action Result 

2 Click on User-Select. 

 

Make sure the Components database is 
selected for use. 

Click Search. 
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 Action Result 

3 Analyze the search results in MineIt. 

 

KnowItAll presents a 3-component search result. The top spectrum is unknown; the bottom 
spectrum is the composite spectrum of 3 components. The middle spectrum is the difference 
between the two. In this case, it is next to nothing, indicating that there are no more residual 
peaks. 

This process accomplishes many steps in one. It also avoids negative peaks from spectral 
subtraction. 
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Adaptive Search 
This search finds similar compounds where a fragment group can be present or missing compared to the unknown. The presence/absence of a 
fragment causes some peak positions in reference MS differing to that of unknown by a delta mass (Δm). KnowItAll shifts some peaks by the Δm 
to achieve a better matching score. Because of the better matching score, similar compounds come atop of the hit list. To clearly mark the shifts 
done by Adaptive Search, dotted lines are used to show reference spectrum before and after shifting in the pop-up window when you click on the 
(i) button in a hit. 

Example wherein exact mass is in a spectrum 
 Action Result 

1 In SearchIt, start a new search by clicking 

. 

Click Spectrum to navigate to 
C:\Users\Public\Documents\Wiley\Know
ItAll\Samples\MS folder. 

Select the file 2-Hydroxybenzoic acid. 

Use the drop-down menu to set the 
Number of components to 1 (Single). 

 

Ensure that either Adaptive Search or 
Reverse Search is unchecked. 

 

 

This spectrum file contains a molecular ion mass of 138. KnowItAll will use this value for the 
Adaptive Search. 
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 Action Result 

2 Click User-Select button 

 

Use Remove All to clean selected 
databases.  

 

Use Limit to spectral technique: and 
select MS (GC). 

 

Scroll down the list and highlight the 
WMS3X database. 

Use Add to add MS (GC) databases by 
codes: WMS3X. 

Click Search. 
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 Action Result 

3 Click the Butterfly view icon . 
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 Action Result 

4 Analyze the 2nd then the 3rd hit. 

 
 
 
Assume that we do not have the first hit in our database. The HQI values for the 2nd and 3rd hits 
are not totally convincing that they are good matches. 
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 Action Result 

5 Go back to SearchIt. 

Click Spectrum MS(GC). 

 

Check Adaptive Search. 

 

Click Search. 

 

  

• If a spectrum file contains the molecular ion mass, it will be displayed in the “Molecular 
m/z:” box, and a solid triangle marks this position in the spectrum pane.  

• You can type in an appropriate value as well. This value is used to assist Adaptive 
Search. 

• Or, you can ask KnowItAll to estimate a molecular mass for you by clicking the bulb icon. 
• However, if molecular ion mass is unknown, this box would be empty. KnowItAll Adapative 

Search will estimate this value from the input unknown MS spectrum. 
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 Action Result 

6 Ignore the 1st hit and move to the 2nd hit. 

Make sure KnowItAll displays implicit 
Hydrogens. Go to the View menu and 
check Implicit Hydrogens. 

 

 

The result looks good. Δm of -14 suggests a few possibilities wherein the unknown’s molecular 
ion mass (m/z) is 14 unit less than that of the reference. One of them is “In unknown, 
Benzene replaces Toluene in reference.” 

Columns of interest: 

• Δm: the molecular ion mass of unknown minus that of the reference 
• Δm Info: details on reference peak shifts to make the match 
• Replacement: suggestions of possible group exchange which would cause the 

difference between unknown and reference molecular ion masses 
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 Action Result 

7 Click (i) icon ( ) in the Δm Info column. 
This brings up the Adaptive Corrections 
html page which explains how selective 
peaks have been shifted to obtain good 
Hit Quality Index (HQI). 

  

8 Analyze the information in the popup for 
Optimized Corrections. 
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 Action Result 

• The top spectrum is the unknown 
• The bottom spectrum is the unshifted reference 
• The middle “spectrum” contains shifted peaks 
• Dotted lines indicate what peaks have been moved by an Δm 
• In the middle “spectrum,” darker red peaks are the additions of existing peaks and moved 

ones 
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Example wherein exact mass is NOT in a spectrum 
 Action Result 

1 
Start a new search by clicking . 

Click Spectrum and navigate to 
C:\Users\Public\Documents\Wiley\KnowI
tAll\Samples\MS folder.  

Select file 1,1,1-Trichlorobutane.  

Use the drop-down menu to set the 
Number of components to 1 (Single). 

 

Ensure either Adaptive Search or Reverse 
Search is unchecked. 

Click User-Select. 

Use Remove All to clean selected 
databases.  

Use Add to add MS (GC) databases by 
codes: WMS3X. 

Click Search. 

 

As we can see, this spectrum does not contain molecular ion mass. KnowItAll will estimate this 
value and use it for Adaptive Search. 
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 Action Result 

2 Click the Butterfly view icon . 
 
Go to the 2nd hit since the 1st hit is the exact 
match (pretend that we do not have the 
exact match in our databases). 

 

 

We are not sure by looking at the HQI that we have a hit that is structurally similar to our 
unknown. 
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 Action Result 

3 Go back to SearchIt. 
 
Check Adaptive Search. 
 

 
 
Click Search. 

 

In MineIt, Click the Butterfly view icon . 

Go to the 2nd hit (1st being the unknown 
which is already in a database). 

 

One of the suggestions in the Replacement cell makes sense. The unknown should have 1 
more Chlorine for a delta mass of 34. 
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Alternatively, one can use the molecular ion mass estimation icon  to estimate the molecular ion mass: 
 

 Action Result 

1 Go Back to SearchIt. 

Click the  icon. 

Let the calculation complete. 

 
2 Click OK button 

The estimated molecular ion mass value fills the box  
 
 
NOTE: KnowItAll runs an adaptive search of the unknown against all of our MS databases. The resulting hit list is then analyzed in steps. The 
mass of every hit list entry is calculated as the nominal mass of the compound in the database record plus the Δm found for the match. Matches of 
equal mass are then grouped together into clusters. The higher the found HQI, the higher the score for an individual match. Scores for clusters are 
then calculated as a combination of individual match scores with additional information such as the number of entries in the cluster and the 
separation from the next best cluster. The cluster with the best score determines the found mass. As side information of this procedure, 
information on confidence that the found mass will be correct is reported.  
The confidence values found by the algorithm were determined by running statistics with thousands of very diverse compound spectra run against 
our MS data.  
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Simultaneous Multiple MS Spectra Search 
 
 Action Result 

1 In SearchIt, select Open Spectrum or 
Structure 
 

 
 
Navigate to 
C:\Users\Public\Documents\Wiley\KnowItA
ll\Samples\GC-MS\Barbiturate GC-MS.d 
 
Click Open in previous dialog.  
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 Action Result 

2 Pick multiple MS spectrum in the MS Spectra 
Scan Selection dialog. 
 
For example, 292, 346, 366. 
 
Click OK button. 
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 Action Result 

3 Multiple search tabs are created. 

  

4 One can either search these MS spectra one 
by one by clicking the Search button in each 
tab. 
 
Or use Batch Search button and reply Yes 
when prompted. 
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 Action Result 

5 Analyze the search results in MineIt: 
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Other Tools for Mass Spectrometry 

Elemental Composition 
 Action Result 

1 Begin in MineIt. From the Menu, navigate 
to MS Tools > Calculate Elemental 
Composition. 

 

You can fill in this dialog with target mass and elemental information. 
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 Action Result 

2 Click Calculate. 

 

KnowItAll provides combinations of these elements. 
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Isotopic Distribution 
 Action Result 

1 Go to ChemWindow. 

Click File > Open. 

Select a structure from the Samples > GC-
MS folder. 
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 Action Result 

2 Navigate to MS Tools > Calculate 
Isotopic Distribution. 

Click Calculate. 
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Molecular Fragmentation 
In ChemWindow, you can use the MS fragmentation tools to view possible fragments and corresponding masses. 
 
 Action Result 

1 Begin in ChemWindow. In the Edit toolbar 
on the left, click on the MS fragmentation 
tool. 
 

 
 
Point to a position, then drag a line—this is 
the fragmentation line. 
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Solid Triangle Marks Nominal Mass 
• In the spectrum display, KnowItAll marks the nominal mass of the structure that corresponds to the spectrum. This mass is shown as a black 

triangle. 
• When importing a spectrum from a data file, a number of import formats define fields for molecular m/z (also called precursor m/z or base 

peak m/z in some cases) and the charge of the molecular ion. To convert from molecular m/z to exact mass, the following formulae are used: 
o For positive charges: 

 Mexact = (Mz – M(H) + M(e)) * charge, where M(H) is the mass of a hydrogen atom, and M(e) is the mass of an electron. 
o For negative charges: 

 Mexact = (Mz - M(e)) * (-charge). 
o If no charge is defined, a default charge of +1 is assumed. 

• If a data file does not have the molecular m/z field defined, the exact mass is calculated from the formula field, if available. 
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